summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2010-11-05 18:38:38 +0100
committerJan Engelhardt <jengelh@medozas.de>2010-11-05 18:38:38 +0100
commit191e7c6ec0e9ad6cb1ad3e90ad331248c7fca2ad (patch)
treef7d802fae14598cbff5da2bab83f96280cf597d8 /configure.ac
parent70c1a7a6cab7e205985de49e5ac42e6e7fd2d841 (diff)
build: run autoupdate to replace obsolete constructs
Signed-off-by: Jan Engelhardt <jengelh@medozas.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 1d5ac2b..7f9110a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,8 +65,7 @@ AC_CHECK_FUNCS(inet_pton)
dnl Some systems have it, but not IPv6
if test "$ac_cv_func_inet_pton" = "yes" ; then
AC_MSG_CHECKING(if inet_pton supports IPv6)
-AC_TRY_RUN(
- [
+AC_RUN_IFELSE([AC_LANG_SOURCE([[
#ifdef HAVE_SYS_TYPES_H
#include <sys/types.h>
#endif
@@ -87,9 +86,9 @@ int main()
else
exit(0);
}
- ], [ AC_MSG_RESULT(yes)
+ ]])],[ AC_MSG_RESULT(yes)
AC_DEFINE_UNQUOTED(HAVE_INET_PTON_IPV6, 1, [Define to 1 if inet_pton supports IPv6.])
- ], AC_MSG_RESULT(no), AC_MSG_RESULT(no))
+ ],[AC_MSG_RESULT(no)],[AC_MSG_RESULT(no)])
fi
# Checks for header files.