summaryrefslogtreecommitdiffstats
path: root/src/helpers/Makefile.am
diff options
context:
space:
mode:
authorKevin Cernekee <cernekee@chromium.org>2016-09-04 19:39:04 -0700
committerPablo Neira Ayuso <pablo@netfilter.org>2016-09-09 00:21:30 +0200
commitdd4b5a1e5e52f2107227b8513fbf87bc4b0df079 (patch)
treea031a06ebea8c62107fd6555c9719526da532301 /src/helpers/Makefile.am
parentd833bed181469876c4182156682ca9e5ebd9bd9a (diff)
conntrackd: cthelper: Add new mdns helper
This allows unicast replies to multicast DNS (mDNS / RFC6762) queries. These queries are often used when a full-featured mDNS service (such as avahi-daemon) is not running, or if an mDNS client does not have permission to bind to port 5353. Signed-off-by: Kevin Cernekee <cernekee@chromium.org> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'src/helpers/Makefile.am')
-rw-r--r--src/helpers/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/helpers/Makefile.am b/src/helpers/Makefile.am
index 78ef7aa..51f4887 100644
--- a/src/helpers/Makefile.am
+++ b/src/helpers/Makefile.am
@@ -3,6 +3,7 @@ include $(top_srcdir)/Make_global.am
pkglib_LTLIBRARIES = ct_helper_amanda.la \
ct_helper_dhcpv6.la \
ct_helper_ftp.la \
+ ct_helper_mdns.la \
ct_helper_rpc.la \
ct_helper_tftp.la \
ct_helper_tns.la \
@@ -21,6 +22,10 @@ ct_helper_ftp_la_SOURCES = ftp.c
ct_helper_ftp_la_LDFLAGS = -avoid-version -module $(LIBNETFILTER_CONNTRACK_LIBS)
ct_helper_ftp_la_CFLAGS = $(AM_CFLAGS) $(LIBNETFILTER_CONNTRACK_CFLAGS)
+ct_helper_mdns_la_SOURCES = mdns.c
+ct_helper_mdns_la_LDFLAGS = -avoid-version -module $(LIBNETFILTER_CONNTRACK_LIBS)
+ct_helper_mdns_la_CFLAGS = $(AM_CFLAGS) $(LIBNETFILTER_CONNTRACK_CFLAGS)
+
ct_helper_rpc_la_SOURCES = rpc.c
ct_helper_rpc_la_LDFLAGS = -avoid-version -module $(LIBNETFILTER_CONNTRACK_LIBS)
ct_helper_rpc_la_CFLAGS = $(AM_CFLAGS) $(LIBNETFILTER_CONNTRACK_CFLAGS)