summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2011-01-20 14:48:23 +0100
committerJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2011-01-20 14:48:23 +0100
commitc8396bdc040f4b16e6f6e3f8b81b9fb67a499d9c (patch)
tree0704d9f117fb9fefed1b9ec5e680e765d80ff877 /Makefile.am
parent13dcc23a375f61d8286072b20067fb31bcc3ad46 (diff)
Use annotated types and fix sparse warnings
Annotated types are introduced and sparse warnings fixed. Two warnings remained in ip_set_core.c but those are false ones. (Patrick McHardy's review)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7d91b8f..8f448ca 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,6 +22,10 @@ endif
SUBDIRS = lib src
+modules_sparse:
+ ${MAKE} -C $(KBUILD_OUTPUT) M=$$PWD/kernel V=$V C=2 CF=-D__CHECK_ENDIAN__ \
+ IP_SET_MAX=$(IP_SET_MAX) modules
+
modules:
${MAKE} -C $(KBUILD_OUTPUT) M=$$PWD/kernel V=$V \
IP_SET_MAX=$(IP_SET_MAX) modules