summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2010-06-29 21:14:40 +0200
committerJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2010-06-29 21:14:40 +0200
commit8dd10256cb24ceade8b40bd1604f03ddac8589e2 (patch)
tree9b6e5deae0b5d349122c82b63019d6bb36a66aeb /Makefile.am
parent780f6384c5c6639da3f5a6ac8d30653e8a26d6c0 (diff)
ipset 5: Sparc related and compatibility fixesv5.0-pre5
ipset 5 is tested on Sparc, which revealed some compatibility issues and those are fixed. Kernels from 2.6.31 onward are supported. The testsuite checkings are completed to run match/target checks. The README file is updated to reflect the requirements to install and run ipset 5.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e5c1c83..7225f86 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,7 +21,10 @@ endif
SUBDIRS = lib src
modules:
- cd kernel; make -C $(KBUILD_OUTPUT) M=`pwd` V=$V IP_SET_MAX=$(IP_SET_MAX) modules
+ cd kernel; make -C $(KBUILD_OUTPUT) M=`pwd` V=$V \
+ IP_SET_MAX=$(IP_SET_MAX) \
+ NETLINK_DUMP_CONST=$(NETLINK_DUMP_CONST) \
+ NFNL_CB_CONST=$(NFNL_CB_CONST) modules
modules_install:
cd kernel; make -C $(KBUILD_OUTPUT) M=`pwd` modules_install