summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2012-05-10 13:31:53 +0200
committerJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2012-05-10 13:31:53 +0200
commite693cf5e152ffa5dd3917a05856e9f10000eb37e (patch)
treee03f74748276cfc4712741da5ff075bb6c089535 /Makefile.am
parent173d19a6e5462373af13e928d860a4db32c36de1 (diff)
Add tarball target to Makefile
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 554a76a..42b9550 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -75,6 +75,13 @@ tidy: distclean modules_clean
rm -rf lib/ipset_settype_check lib/types_init.c
find . -name '*~' -delete
-.PHONY: modules modules_instal modules_clean update_includes tests
+tarball:
+ rm -Rf /tmp/ipset-${PACKAGE_VERSION};
+ pushd ${top_srcdir} && git archive --prefix=ipset-${PACKAGE_VERSION}/ HEAD | tar -C /tmp -x && popd;
+ pushd /tmp/ipset-${PACKAGE_VERSION} && ./autogen.sh && popd;
+ tar -C /tmp -cjf ipset-${PACKAGE_VERSION}.tar.bz2 --owner=root --group=root ipset-${PACKAGE_VERSION}/;
+ rm -Rf /tmp/ipset-${PACKAGE_VERSION};
+
+.PHONY: modules modules_instal modules_clean update_includes tests tarball
DISTCHECK_CONFIGURE_FLAGS = --with-kmod=no