summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJozsef Kadlecsik <kadlec@netfilter.org>2020-01-20 19:59:43 +0100
committerJozsef Kadlecsik <kadlec@netfilter.org>2020-01-20 19:59:43 +0100
commit3f685a1f904daf5fe29adcabf9474c1c35f85db1 (patch)
tree1daff45661096f92061451f9c580e19788c6d047 /configure.ac
parentb661f385ab7457f4d45b2693631b590aa26c8a8f (diff)
Add compatibility support for bitmap_zalloc() and bitmap_zero()
Signed-off-by: Jozsef Kadlecsik <kadlec@netfilter.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a2694bb..69a97a9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -429,6 +429,26 @@ else
AC_SUBST(HAVE_KVFREE, undef)
fi
+AC_MSG_CHECKING([kernel source for bitmap_zalloc])
+if test -f $ksourcedir/include/linux/bitmap.h && \
+ $GREP -q 'bitmap_zalloc' $ksourcedir/include/linux/bitmap.h; then
+ AC_MSG_RESULT(yes)
+ AC_SUBST(HAVE_BITMAP_ZALLOC, define)
+else
+ AC_MSG_RESULT(no)
+ AC_SUBST(HAVE_BITMAP_ZALLOC, undef)
+fi
+
+AC_MSG_CHECKING([kernel source for bitmap_zero])
+if test -f $ksourcedir/include/linux/bitmap.h && \
+ $GREP -q 'bitmap_zero' $ksourcedir/include/linux/bitmap.h; then
+ AC_MSG_RESULT(yes)
+ AC_SUBST(HAVE_BITMAP_ZERO, define)
+else
+ AC_MSG_RESULT(no)
+ AC_SUBST(HAVE_BITMAP_ZERO, undef)
+fi
+
AC_MSG_CHECKING([kernel source for struct net in struct xt_mtchk_param])
if test -f $ksourcedir/include/linux/netfilter/x_tables.h && \
$AWK '/^struct xt_mtchk_param /,/^}/' $ksourcedir/include/linux/netfilter/x_tables.h | \