summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJozsef Kadlecsik <kadlec@netfilter.org>2023-09-18 23:06:59 +0200
committerJozsef Kadlecsik <kadlec@netfilter.org>2023-09-18 23:06:59 +0200
commit540bc5a6fd544a35317674084efc45e22c5e3692 (patch)
tree0effea71d6228aeac9ddb2e290b145b3b4bbe1f7 /configure.ac
parentcc36d5415859c73db18da4925059e5b4cd7d30b9 (diff)
compatibility: handle strscpy_pad()
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index dc11b14..59a3421 100644
--- a/configure.ac
+++ b/configure.ac
@@ -754,6 +754,16 @@ else
AC_SUBST(HAVE_STRSCPY, undef)
fi
+AC_MSG_CHECKING([kernel source for strscpy_pad() in string.h])
+if test -f $ksourcedir/include/linux/timer.h && \
+ $GREP -q ' strscpy_pad' $ksourcedir/include/linux/string.h; then
+ AC_MSG_RESULT(yes)
+ AC_SUBST(HAVE_STRSCPY_PAD, define)
+else
+ AC_MSG_RESULT(no)
+ AC_SUBST(HAVE_STRSCPY, undef)
+fi
+
AC_MSG_CHECKING([kernel source for synchronize_rcu_bh() in rcutiny.h and rcupdate.h])
if test -f $ksourcedir/include/linux/rcupdate.h && \
$GREP -q 'static inline void synchronize_rcu_bh' \