summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2010-12-18 23:02:48 +0100
committerJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2010-12-18 23:02:48 +0100
commit18ae855bc06472e7fa714ec177f2db4b32f82d8a (patch)
tree64552d00215227676b6909e85a825fe5c5f7657d /configure.ac
parentc35dbd0a66f5abede84a4ea966bd765ed6942edb (diff)
Check from `configure` that the kernel source is patched with netlink.patch
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5ac7c86..85073f4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,6 +56,11 @@ then
AC_MSG_ERROR([The kernel build directory $kbuilddir is not configured with IP6_NF_IPTABLES support (ip6tables)])
fi
+if test "X`$GREP 'NFNL_SUBSYS_IPSET' $ksourcedir/include/linux/netfilter/nfnetlink.h`" = "X"
+then
+ AC_MSG_ERROR([The kernel source directory $ksourcedir is not patched with netlink.patch to support ipset])
+fi
+
dnl Check kernel dependencies: nfnetlink.h
NFNL_CB_CONST="`./check_const $ksourcedir/include/linux/netfilter/nfnetlink.h`"
AC_SUBST(NFNL_CB_CONST)