summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2010-06-16 22:49:16 +0200
committerJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2010-06-16 22:49:16 +0200
commit97a12ba3f184a76c406eb5622ec21a4d4d6fc8bf (patch)
treefd6a6d6066ca591b42c0efb6218487401347a20f /configure.ac
parent17116e637e9fd32d67ebdfbd10b465b3dec50c03 (diff)
configure/Makefile and debug fixes
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cfffa99..658d5f0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,6 +39,18 @@ AC_ARG_ENABLE([verbose],
AM_CONDITIONAL([ENABLE_VERBOSE], [test "x$enable_verbose" = xyes])
+dnl Enable debugging
+AC_ARG_ENABLE([debug],
+ AS_HELP_STRING([--enable-debug],
+ [Enable compiling with debug support.]),
+ [case "${enableval}" in
+ yes) enable_verbose=yes ;;
+ no) enable_verbose=no ;;
+ *) AC_MSG_ERROR([bad value ${enableval} for --enable-debug]) ;;
+ esac], [enable_debug=no])
+
+AM_CONDITIONAL([ENABLE_DEBUG], [test "x$enable_debug" = xyes])
+
dnl Disable extra warn flags
AC_ARG_ENABLE([extra-flags],
AS_HELP_STRING([--disable-extra-flags],