summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJiri Benc <jbenc@redhat.com>2015-06-13 21:46:47 +0200
committerJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2015-06-13 21:46:47 +0200
commit01a13aa4fe0cb668fc535d38d6f9383433923874 (patch)
treec173f64894115c330c0b2468835ff05a1158218a /configure.ac
parent5e1734cedd68725dbcda83626c25a15c812e4eb4 (diff)
netlink: implement nla_put_in_addr and nla_put_in6_addr
IP addresses are often stored in netlink attributes. Add generic functions to do that. For nla_put_in_addr, it would be nicer to pass struct in_addr but this is not used universally throughout the kernel, in way too many places __be32 is used to store IPv4 address. Signed-off-by: Jiri Benc <jbenc@redhat.com> Signed-off-by: David S. Miller <davem@davemloft.net> Compatibility part added. Signed-off-by: Jozsef Kadlecsik <kadlec@blackhole.kfki.hu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c032bf6..6b6ba1f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -416,6 +416,16 @@ else
AC_SUBST(HAVE_NF_BRIDGE_GET_PHYSDEV, undef)
fi
+AC_MSG_CHECKING([kernel source for nla_put_in_addr])
+if test -f $ksourcedir/include/net/netlink.h && \
+ $GREP -q 'nla_put_in_add' $ksourcedir/include/net/netlink.h; then
+ AC_MSG_RESULT(yes)
+ AC_SUBST(HAVE_NLA_PUT_IN_ADDR, define)
+else
+ AC_MSG_RESULT(no)
+ AC_SUBST(HAVE_NLA_PUT_IN_ADDR, undef)
+fi
+
AC_MSG_CHECKING([kernel source for struct net_generic])
if test -f $ksourcedir/include/net/netns/generic.h && \
$GREP -q 'struct net_generic' $ksourcedir/include/net/netns/generic.h; then