summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2014-12-17 07:44:37 +0100
committerJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2015-01-06 08:24:32 +0100
commitc350a7f39402ace2456abe609beb2e6d53b3127a (patch)
tree522a4e02e1d2d22c78410193ad4b22c13d22d48c /configure.ac
parent9f497f7e3c931ab8e09bf34957bf652baa0a7fdd (diff)
Compatibility: check kernel source for list_last_entry
list_last_entry is missing on CentOS7, reported by Ricardo Klein.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4212274..74bc7de 100644
--- a/configure.ac
+++ b/configure.ac
@@ -376,6 +376,16 @@ else
AC_SUBST(HAVE_TCF_EMATCH_STRUCT_NET, undef)
fi
+AC_MSG_CHECKING([kernel source for list_last_entry])
+if test -f $ksourcedir/include/linux/list.h && \
+ $GREP -q 'list_last_entry' $ksourcedir/include/linux/list.h; then
+ AC_MSG_RESULT(yes)
+ AC_SUBST(HAVE_LIST_LAST_ENTRY, define)
+else
+ AC_MSG_RESULT(no)
+ AC_SUBST(HAVE_LIST_LAST_ENTRY, undef)
+fi
+
AC_MSG_CHECKING([kernel source for struct net_generic])
if test -f $ksourcedir/include/net/netns/generic.h && \
$GREP -q 'struct net_generic' $ksourcedir/include/net/netns/generic.h; then