summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMart Frauenlob <mart.frauenlob@chello.at>2016-02-25 16:01:40 +0100
committerJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2016-02-26 19:59:29 +0100
commit3b0941302c0940e625ea545b096a20319a0d8a19 (patch)
tree5763444dd4a88ab66a065d4e763fd9c0fcda0e6c /configure.ac
parent7de1b275f16528509ec93bcc1f3ffa81f2d9faa8 (diff)
Add bash completion to the install routine.
Add the configure option --enable-bashcompl (default disabled). The PKG_CHECK_VAR requires pkg-config 0.28 or greater. Signed-off-by: Mart Frauenlob <mart.frauenlob@chello.at> Signed-off-by: Jozsef Kadlecsik <kadlec@blackhole.kfki.hu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 390673c..1de0808 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,6 +39,17 @@ AC_ARG_WITH([ksource],
AM_CONDITIONAL(WITH_KBUILDDIR, test "$KBUILDDIR" != "")
AC_SUBST(KBUILDDIR)
+dnl ipset bash compspec - bash shell programmable completion
+AC_ARG_ENABLE([bashcompl],
+ AS_HELP_STRING([--enable-bashcompl],
+ [Install bash completion for ipset]),
+ [enable_bashcompl="$enableval"], [enable_bashcompl="no"])
+
+if test "x$enable_bashcompl" = "xyes"; then
+ PKG_CHECK_VAR(bashcompdir, [bash-completion], [completionsdir], , bashcompdir="${sysconfdir}/bash_completion.d")
+ AC_SUBST(bashcompdir)
+fi
+
if test "$BUILDKMOD" == "yes"
then
dnl Sigh: check kernel version dependencies
@@ -501,13 +512,16 @@ dnl Checks for library functions.
dnl Generate output
AC_CONFIG_FILES([Makefile include/libipset/Makefile
- lib/Makefile lib/libipset.pc src/Makefile
+ lib/Makefile lib/libipset.pc src/Makefile utils/Makefile
kernel/include/linux/netfilter/ipset/ip_set_compat.h])
AC_OUTPUT
dnl Summary
AC_MSG_RESULT([])
AC_MSG_RESULT([$PACKAGE userspace tool configuration:])
+if test "x$bashcompdir" != "x"; then
+ AC_MSG_RESULT([ Bash completion directory: ${bashcompdir}])
+fi
if test "x$enable_settype_modules" != "xyes"; then
AC_MSG_RESULT([ Dynamic module loading: disabled])
else