summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2015-04-17 20:39:34 +0200
committerJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2015-04-17 20:39:34 +0200
commit8bd2debcb473edb6b1550e9b510838456a7fd0f3 (patch)
tree3a5d53681a18e06252f19fde282833d81766ad85 /configure.ac
parente91b76ec03b3d7aa8a5f182472f9a954e8368ea8 (diff)
Fix coding styles reported by the most recent checkpatch.pl.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0e9d054..a6b86a9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -396,6 +396,16 @@ else
AC_SUBST(HAVE_LIST_NEXT_ENTRY, undef)
fi
+AC_MSG_CHECKING([kernel source for ether_addr_copy])
+if test -f $ksourcedir/include/linux/etherdevice.h && \
+ $GREP -q 'ether_addr_copy' $ksourcedir/include/linux/etherdevice.h; then
+ AC_MSG_RESULT(yes)
+ AC_SUBST(HAVE_ETHER_ADDR_COPY, define)
+else
+ AC_MSG_RESULT(no)
+ AC_SUBST(HAVE_ETHER_ADDR_COPY, undef)
+fi
+
AC_MSG_CHECKING([kernel source for struct net_generic])
if test -f $ksourcedir/include/net/netns/generic.h && \
$GREP -q 'struct net_generic' $ksourcedir/include/net/netns/generic.h; then