summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJiri Pirko <jiri@resnulli.us>2016-10-11 22:09:08 +0200
committerJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2016-10-11 22:09:08 +0200
commitf0c110ecc4b8b04e1bbf6766284d3bf52cd73a30 (patch)
treec316da5f31598e8dffff938979e1950fc30ed42b /configure.ac
parent15d7b6d7a3615c897438955257a7a4f0390ff1d8 (diff)
net: sched: fix skb->protocol use in case of accelerated vlan path
tc code implicitly considers skb->protocol even in case of accelerated vlan paths and expects vlan protocol type here. However, on rx path, if the vlan header was already stripped, skb->protocol contains value of next header. Similar situation is on tx path. So for skbs that use skb->vlan_tci for tagging, use skb->vlan_proto instead. Reported-by: Jamal Hadi Salim <jhs@mojatatu.com> Signed-off-by: Jiri Pirko <jiri@resnulli.us> Acked-by: Jamal Hadi Salim <jhs@mojatatu.com> Signed-off-by: David S. Miller <davem@davemloft.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b73b3cc..f046e8b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -487,6 +487,16 @@ else
AC_SUBST(HAVE_EXPORT_SYMBOL_GPL_IN_MODULE_H, undef)
fi
+AC_MSG_CHECKING([kernel source for tc_skb_protocol in pkt_sched.h])
+if test -f $ksourcedir/include/net/pkt_sched.h && \
+ $GREP -q 'tc_skb_protocol' $ksourcedir/include/net/pkt_sched.h; then
+ AC_MSG_RESULT(yes)
+ AC_SUBST(HAVE_TC_SKB_PROTOCOL, define)
+else
+ AC_MSG_RESULT(no)
+ AC_SUBST(HAVE_TC_SKB_PROTOCOL, undef)
+fi
+
AC_MSG_CHECKING([kernel source for struct net_generic])
if test -f $ksourcedir/include/net/netns/generic.h && \
$GREP -q 'struct net_generic' $ksourcedir/include/net/netns/generic.h; then