summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2014-12-29 22:28:17 +0100
committerJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2015-01-06 08:25:09 +0100
commitf1d7b4b97f82c5fb912e0857818cbec07d264b23 (patch)
tree034c4d665ccd1c1e1ae64b066e2c65580547619d /configure.ac
parentf5faf94ec994b470ad4a23daa0218a75c5003f46 (diff)
More compatibility checking and simplifications
Try hard to keep the support of the 2.6.32 kernel tree and simplify the code with self-referential macros.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 74bc7de..0e9d054 100644
--- a/configure.ac
+++ b/configure.ac
@@ -386,6 +386,16 @@ else
AC_SUBST(HAVE_LIST_LAST_ENTRY, undef)
fi
+AC_MSG_CHECKING([kernel source for list_next_entry])
+if test -f $ksourcedir/include/linux/list.h && \
+ $GREP -q 'list_next_entry' $ksourcedir/include/linux/list.h; then
+ AC_MSG_RESULT(yes)
+ AC_SUBST(HAVE_LIST_NEXT_ENTRY, define)
+else
+ AC_MSG_RESULT(no)
+ AC_SUBST(HAVE_LIST_NEXT_ENTRY, undef)
+fi
+
AC_MSG_CHECKING([kernel source for struct net_generic])
if test -f $ksourcedir/include/net/netns/generic.h && \
$GREP -q 'struct net_generic' $ksourcedir/include/net/netns/generic.h; then