summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJozsef Kadlecsik <kadlec@netfilter.org>2020-12-20 14:11:06 +0100
committerJozsef Kadlecsik <kadlec@netfilter.org>2020-12-20 14:11:06 +0100
commit0281117233dd91f93d3cbc01ef64247933549b52 (patch)
treecd5efecb2de624490745420bbfa058ce091a0c9d /configure.ac
parente1db281ca1debde3d0ef66a6aa130469d449c301 (diff)
Backward compatibility: handle renaming nla_strlcpy to nla_strscpy
Signed-off-by: Jozsef Kadlecsik <kadlec@netfilter.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2f06590..c777eed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -725,6 +725,16 @@ else
AC_SUBST(HAVE_LOCKDEP_NFNL_IS_HELD, undef)
fi
+AC_MSG_CHECKING([kernel source for nla_strscpy() in netlink.h])
+if test -f $ksourcedir/include/net/netlink.h && \
+ $GREP -q ' nla_strscpy' $ksourcedir/include/net/netlink.h; then
+ AC_MSG_RESULT(yes)
+ AC_SUBST(HAVE_NLA_STRSCPY, define)
+else
+ AC_MSG_RESULT(no)
+ AC_SUBST(HAVE_NLA_STRSCPY, undef)
+fi
+
AC_MSG_CHECKING([kernel source for strscpy() in string.h])
if test -f $ksourcedir/include/linux/timer.h && \
$GREP -q ' strscpy' $ksourcedir/include/linux/string.h; then