summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2018-01-03 10:57:31 +0100
committerJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2018-01-03 10:57:31 +0100
commit0a81ab50306539788e2dd0471f3b1ed5b9dcc5ef (patch)
tree995fcac0cdf514dcd941da9a10d0ab580e74871b /configure.ac
parentd71dd93599b932693f045301424c2276cd25a87e (diff)
Backport patch: netfilter: ipset: Convert timers to use timer_setup()
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0c01680..9b6c907 100644
--- a/configure.ac
+++ b/configure.ac
@@ -589,6 +589,16 @@ else
AC_SUBST(HAVE_TYPEDEF_SCTP_SCTPHDR_T, undef)
fi
+AC_MSG_CHECKING([kernel source for timer_setup in timer.h])
+if test -f $ksourcedir/include/linux/timer.h && \
+ $GREP -q ' timer_setup' $ksourcedir/include/linux/timer.h; then
+ AC_MSG_RESULT(yes)
+ AC_SUBST(HAVE_TIMER_SETUP, define)
+else
+ AC_MSG_RESULT(no)
+ AC_SUBST(HAVE_TIMER_SETUP, undef)
+fi
+
AC_MSG_CHECKING([kernel source for struct net_generic])
if test -f $ksourcedir/include/net/netns/generic.h && \
$GREP -q 'struct net_generic' $ksourcedir/include/net/netns/generic.h; then