summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorFlorian Westphal <fw@strlen.de>2015-04-27 21:48:33 +0200
committerJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2015-04-27 21:49:25 +0200
commit3fdc27aaad9cd644ddaae6f2dba6f13b5e78f27f (patch)
tree7b8605a5026efd6e09e04210a0883abb469811c9 /configure.ac
parent00a3c3dd11e54c3d98c11f081e8d05d2d27aa11d (diff)
netfilter: bridge: add helpers for fetching physin/outdevpablo
right now we store this in the nf_bridge_info struct, accessible via skb->nf_bridge. This patch prepares removal of this pointer from skb: Instead of using skb->nf_bridge->x, we use helpers to obtain the in/out device (or ifindexes). Followup patches to netfilter will then allow nf_bridge_info to be obtained by a call into the br_netfilter core, rather than keeping a pointer to it in sk_buff. Signed-off-by: Florian Westphal <fw@strlen.de> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org> Signed-off-by: Jozsef Kadlecsik <kadlec@blackhole.kfki.hu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a6b86a9..c032bf6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -406,6 +406,16 @@ else
AC_SUBST(HAVE_ETHER_ADDR_COPY, undef)
fi
+AC_MSG_CHECKING([kernel source for nf_bridge_get_physindev])
+if test -f $ksourcedir/include/linux/netfilter_bridge.h && \
+ $GREP -q 'nf_bridge_get_physindev' $ksourcedir/include/linux/netfilter_bridge.h; then
+ AC_MSG_RESULT(yes)
+ AC_SUBST(HAVE_NF_BRIDGE_GET_PHYSDEV, define)
+else
+ AC_MSG_RESULT(no)
+ AC_SUBST(HAVE_NF_BRIDGE_GET_PHYSDEV, undef)
+fi
+
AC_MSG_CHECKING([kernel source for struct net_generic])
if test -f $ksourcedir/include/net/netns/generic.h && \
$GREP -q 'struct net_generic' $ksourcedir/include/net/netns/generic.h; then