summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJozsef Kadlecsik <kadlec@netfilter.org>2021-06-26 22:17:58 +0200
committerJozsef Kadlecsik <kadlec@netfilter.org>2021-06-26 22:17:58 +0200
commit677895d0ac5b0c3b46ef3200e961a708d5601c1e (patch)
treed1d291431ddce067999c05d9d2a4eb2b7c65bf0d /configure.ac
parentfd7d97c57e9dbe215c71be5a2fe049a1f905fddb (diff)
Backport "netfilter: add helper function to set up the nfnetlink header and use it"
Backport patch "netfilter: add helper function to set up the nfnetlink header and use it" from Pablo Neira Ayuso <pablo@netfilter.org>. Signed-off-by: Jozsef Kadlecsik <kadlec@netfilter.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bd6116c..9aea004 100644
--- a/configure.ac
+++ b/configure.ac
@@ -786,6 +786,16 @@ else
AC_SUBST(HAVE_NLA_POLICY_EXACT_LEN, undef)
fi
+AC_MSG_CHECKING([kernel source for nfnl_msg_put() in nfnetlink.h])
+if test -f $ksourcedir/include/linux/netfilter/nfnetlink.h && \
+ $GREP -q 'nfnl_msg_put' $ksourcedir/include/linux/netfilter/nfnetlink.h; then
+ AC_MSG_RESULT(yes)
+ AC_SUBST(HAVE_NFNL_MSG_PUT, define)
+else
+ AC_MSG_RESULT(no)
+ AC_SUBST(HAVE_NFNL_MSG_PUT, undef)
+fi
+
AC_MSG_CHECKING([kernel source for kvzalloc() in mm.h])
if test -f $ksourcedir/include/linux/mm.h && \
$GREP -q 'static inline void \*kvzalloc(' $ksourcedir/include/linux/mm.h; then