summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorOliver Smith <oliver@8.c.9.b.0.7.4.0.1.0.0.2.ip6.arpa>2013-10-11 16:41:12 +0200
committerJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2013-10-17 11:37:50 +0200
commita76488a84db452865e114336b3fde6257e327715 (patch)
treec468cfee399d2c4c8e7cd6afcf1e4967d32dc8d5 /configure.ac
parent1ba17771f624fb3b3fa5526b31c578f6d79b09df (diff)
netfilter: ipset: Fix configure failure when --with-kmod=no
When configuring the sources to build without kernel modules, the path to the kernel sources was not set and the kernel header files were still checked. Now, we do not check the kernel sources for compatibility if we're not going to build any kernel modules. Signed-off-by: Oliver Smith <oliver@8.c.9.b.0.7.4.0.1.0.0.2.ip6.arpa> Signed-off-by: Jozsef Kadlecsik <kadlec@blackhole.kfki.hu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0eb1022..d56328c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -167,6 +167,8 @@ AC_CHECK_TYPES([union nf_inet_addr],,,[#include <linux/types.h>
dnl Checks for functions
AC_CHECK_FUNCS(gethostbyname2)
+if test "$BUILDKMOD" == "yes"
+then
dnl Check kernel incompatibilities... Ugly like hell
AC_MSG_CHECKING([kernel source for struct xt_action_param])
if test -f $ksourcedir/include/linux/netfilter/x_tables.h && \
@@ -309,6 +311,7 @@ else
AC_MSG_RESULT(no)
AC_MSG_ERROR([Netns support is required in the Linux kernel tree])
fi
+fi
dnl Checks for compiler characteristics.
dnl Check extra warning flags except