summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2012-01-05 21:30:20 +0100
committerJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2012-01-05 21:30:20 +0100
commite57d6caa8ddbe268adea991bcf6e58dc6ca43389 (patch)
tree187e09fd0bcb6d4e536a7aa27e4f4c6976c622be /lib/Makefile.am
parentf4b2c3b617333b5a0f359edccc9a9be34d9f36bd (diff)
Set types moved into libipset library
The libipset library is complete by this step, and "ipset" just a CLI interface based on the lib.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index d4ea6d6..3d43523 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -15,7 +15,18 @@ libipset_la_SOURCES = \
parse.c \
print.c \
session.c \
- types.c
+ types.c \
+ ipset_bitmap_ip.c \
+ ipset_bitmap_ipmac.c \
+ ipset_bitmap_port.c \
+ ipset_hash_ip.c \
+ ipset_hash_ipport.c \
+ ipset_hash_ipportip.c \
+ ipset_hash_ipportnet.c \
+ ipset_hash_net.c \
+ ipset_hash_netport.c \
+ ipset_hash_netiface.c \
+ ipset_list_set.c
#%.o: %.c
# ${AM_VERBOSE_CC} ${CC} ${AM_DEPFLAGS} ${AM_CFLAGS} ${CFLAGS} -o $@ -c $<