summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cfffa99..658d5f0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,6 +39,18 @@ AC_ARG_ENABLE([verbose],
AM_CONDITIONAL([ENABLE_VERBOSE], [test "x$enable_verbose" = xyes])
+dnl Enable debugging
+AC_ARG_ENABLE([debug],
+ AS_HELP_STRING([--enable-debug],
+ [Enable compiling with debug support.]),
+ [case "${enableval}" in
+ yes) enable_verbose=yes ;;
+ no) enable_verbose=no ;;
+ *) AC_MSG_ERROR([bad value ${enableval} for --enable-debug]) ;;
+ esac], [enable_debug=no])
+
+AM_CONDITIONAL([ENABLE_DEBUG], [test "x$enable_debug" = xyes])
+
dnl Disable extra warn flags
AC_ARG_ENABLE([extra-flags],
AS_HELP_STRING([--disable-extra-flags],