summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 1 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index af19bf4..728d7aa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,6 +5,7 @@ AC_CANONICAL_HOST
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_HEADER([config.h])
AM_INIT_AUTOMAKE([foreign subdir-objects tar-pax])
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
AC_ENABLE_STATIC
LT_INIT([dlopen])
@@ -91,18 +92,6 @@ AC_ARG_ENABLE([verbose],
*) AC_MSG_ERROR([bad value ${enableval} for --enable-verbose]) ;;
esac], [enable_verbose=no])
-AM_CONDITIONAL([ENABLE_VERBOSE], [test "x$enable_verbose" = xyes])
-
-dnl Enable debugging
-AC_ARG_ENABLE([debug],
- AS_HELP_STRING([--enable-debug],
- [Enable compiling with debug support.]),
- [case "${enableval}" in
- yes) enable_verbose=yes ;;
- no) enable_verbose=no ;;
- *) AC_MSG_ERROR([bad value ${enableval} for --enable-debug]) ;;
- esac], [enable_debug=no])
-
AM_CONDITIONAL([ENABLE_DEBUG], [test "x$enable_debug" = xyes])
dnl Enable type modules