summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f75ef49..7622ac4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,6 +32,18 @@ then
AC_MSG_ERROR([Invalid kernel build directory $kbuilddir])
fi
+if test ! -e "$kbuilddir/.config"
+then
+ AC_MSG_ERROR([The kernel build directory $kbuilddir is not configured])
+fi
+
+AC_PROG_GREP
+
+if test "X`$GREP '^CONFIG_IP6_NF_IPTABLES=' $kbuilddir/.config`" = "X"
+then
+ AC_MSG_ERROR([The kernel build directory $kbuilddir is not configured with IP6_NF_IPTABLES support (ip6tables)])
+fi
+
dnl Check kernel dependencies: nfnetlink.h
NFNL_CB_CONST="`./check_const $kbuilddir/include/linux/netfilter/nfnetlink.h`"
AC_SUBST(NFNL_CB_CONST)