summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
author/C=EU/ST=EU/CN=Patrick McHardy/emailAddress=kaber@trash.net </C=EU/ST=EU/CN=Patrick McHardy/emailAddress=kaber@trash.net>2008-01-29 13:32:07 +0000
committer/C=EU/ST=EU/CN=Patrick McHardy/emailAddress=kaber@trash.net </C=EU/ST=EU/CN=Patrick McHardy/emailAddress=kaber@trash.net>2008-01-29 13:32:07 +0000
commit34d95f7df2fa4252766f42ed5f50c5f2828080d1 (patch)
tree08f9e7c7545c7d4a07179ad0bce3086dbb6e7448 /Makefile.am
parenta209cb634b4f246308dc051ec11c7ad5caf22883 (diff)
[PATCH]: Give preference to iptables header files
Have the header files in the iptables source tree take precedence over those from the kernel source. Otherwise, building the current iptables from subversion just fails with kernels < 2.6.25. Signed-off-by: Jan Engelhardt <jengelh@computergmbh.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 17c78a7..a0f33c6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,10 @@
# -*- Makefile -*-
AUTOMAKE_OPTIONS = foreign subdir-objects
-AM_CFLAGS = ${regular_CFLAGS} -I${top_srcdir}/include
+
+regular_CFLAGS := @regular_CFLAGS@
+kinclude_CFLAGS := @kinclude_CFLAGS@
+AM_CFLAGS = ${regular_CFLAGS} -I${top_srcdir}/include ${kinclude_CFLAGS}
SUBDIRS := extensions
if ENABLE_DEVEL
SUBDIRS += libipq