summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2009-01-12 07:21:20 +0100
committerPatrick McHardy <kaber@trash.net>2009-01-12 07:21:20 +0100
commit52edda6cd97778721f76307c0f21bfc39b8533ac (patch)
tree38404c1b4e874305dd97472c95ec0f4bb6b93ea1 /Makefile.am
parentfea74bf74ff524431ce65145f1523584edf99dc9 (diff)
build: use regular = assignments in Makefile
Resolves warnings: Makefile.am:7: `:='-style assignments are not portable Makefile.am:71: `:='-style assignments are not portable etc. Signed-off-by: Jan Engelhardt <jengelh@medozas.de> Signed-off-by: Patrick McHardy <kaber@trash.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 10 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index fd4d93f9..d5f88756 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,7 +4,7 @@ ACLOCAL_AMFLAGS = -I m4
AUTOMAKE_OPTIONS = foreign subdir-objects
AM_CFLAGS = ${regular_CFLAGS} -I${top_builddir}/include -I${top_srcdir}/include ${kinclude_CFLAGS}
-SUBDIRS := extensions
+SUBDIRS = extensions
if ENABLE_LIBIPQ
SUBDIRS += libipq
endif
@@ -68,16 +68,16 @@ ip6tables_static_SOURCES = ${ip6tables_multi_SOURCES} xtables.c
ip6tables_static_CFLAGS = ${ip6tables_multi_CFLAGS} -DNO_SHARED_LIBS=1
ip6tables_static_LDADD = -lm libiptc/libiptc.a extensions/libext6.a
-noinst_LIBRARIES := libiptc/libiptc.a
-bin_PROGRAMS := iptables-xml
-sbin_PROGRAMS :=
-noinst_PROGRAMS :=
-man_MANS := iptables.8 iptables-restore.8 iptables-save.8 \
- iptables-xml.8 ip6tables.8 ip6tables-restore.8 \
- ip6tables-save.8
-CLEANFILES := iptables.8 ip6tables.8
+noinst_LIBRARIES = libiptc/libiptc.a
+bin_PROGRAMS = iptables-xml
+sbin_PROGRAMS =
+noinst_PROGRAMS =
+man_MANS = iptables.8 iptables-restore.8 iptables-save.8 \
+ iptables-xml.8 ip6tables.8 ip6tables-restore.8 \
+ ip6tables-save.8
+CLEANFILES = iptables.8 ip6tables.8
if ENABLE_DEVEL
-include_HEADERS := include/xtables.h
+include_HEADERS = include/xtables.h
endif
if ENABLE_STATIC