summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2008-09-01 14:27:19 +0200
committerPatrick McHardy <kaber@trash.net>2008-09-01 14:27:19 +0200
commit9e812285f071696c867adfb344dc0eb19af7136a (patch)
treeb396df90b9d98667ec019e4928d10de4709086a5 /Makefile.am
parentddac6c5bc636003d664d25c08ea3fe176565096c (diff)
build: prepare make tarball for git 1.6.0
Git 1.6.0 will not have the dashful forms anymore. Signed-off-by: Jan Engelhardt <jengelh@medozas.de> Signed-off-by: Patrick McHardy <kaber@trash.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 066dc562..742e3de0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -101,7 +101,7 @@ pkgconfig_DATA = xtables.pc
.PHONY: tarball
tarball:
rm -Rf /tmp/${PACKAGE_TARNAME}-${PACKAGE_VERSION};
- pushd ${top_srcdir} && git-archive --prefix=${PACKAGE_TARNAME}-${PACKAGE_VERSION}/ HEAD | tar -C /tmp -x && popd;
+ pushd ${top_srcdir} && git archive --prefix=${PACKAGE_TARNAME}-${PACKAGE_VERSION}/ HEAD | tar -C /tmp -x && popd;
pushd /tmp/${PACKAGE_TARNAME}-${PACKAGE_VERSION} && ./autogen.sh && popd;
tar -C /tmp -cjf ${PACKAGE_TARNAME}-${PACKAGE_VERSION}.tar.bz2 --owner=root --group=root ${PACKAGE_TARNAME}-${PACKAGE_VERSION}/;
rm -Rf /tmp/${PACKAGE_TARNAME}-${PACKAGE_VERSION};