summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2008-03-03 13:04:07 +0100
committerPatrick McHardy <kaber@trash.net>2008-04-06 17:40:41 +0200
commita31cdd88d7af44bc6c1e45b248ca3224363e1ba1 (patch)
tree8cf312812a08ea25cb01c3e17074d6b05a511260 /Makefile.am
parent5180032804c03225542368aaaf19060fe7a47a1c (diff)
Makefile: add a "tarball" target
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a0f33c62..112b5525 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -93,3 +93,11 @@ ip6tables.8: ${srcdir}/ip6tables.8.in extensions/matches6.man extensions/targets
extensions/%:
${MAKE} ${AM_MAKEFLAGS} -C $(@D) $(@F)
+
+.PHONY: tarball
+tarball:
+ rm -Rf /tmp/xtables-${PACKAGE_VERSION};
+ pushd ${top_srcdir} && git-archive --prefix=xtables-${PACKAGE_VERSION}/ HEAD | tar -C /tmp -x && popd;
+ pushd /tmp/xtables-${PACKAGE_VERSION} && ./autogen.sh && popd;
+ tar -C /tmp -cjf xtables-${PACKAGE_VERSION}.tar.bz2 --owner=root --group=root xtables-${PACKAGE_VERSION}/;
+ rm -Rf /tmp/xtables-${PACKAGE_VERSION};