summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2009-02-12 15:01:37 +0100
committerJan Engelhardt <jengelh@medozas.de>2009-02-12 15:13:18 +0100
commitf567ac9193bc421992e572ec3196a73dc6ed59c0 (patch)
treed43ac3b4bfc44654eb6ab864658610b241e1dc36 /Makefile.am
parent228b4bda8f21f8730b10c156822bc988d77e891b (diff)
build: restructure Makefile for include/ directory
This patch will support adding libiptc to the headers list in future. Signed-off-by: Jan Engelhardt <jengelh@medozas.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index dbdfa97a..be3f55eb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,6 +5,9 @@ AUTOMAKE_OPTIONS = foreign subdir-objects
AM_CFLAGS = ${regular_CFLAGS} -I${top_builddir}/include -I${top_srcdir}/include ${kinclude_CFLAGS}
SUBDIRS = extensions
+if ENABLE_DEVEL
+SUBDIRS += include
+endif
if ENABLE_LIBIPQ
SUBDIRS += libipq
endif
@@ -78,9 +81,6 @@ man_MANS = iptables.8 iptables-restore.8 iptables-save.8 \
iptables-xml.8 ip6tables.8 ip6tables-restore.8 \
ip6tables-save.8
CLEANFILES = iptables.8 ip6tables.8
-if ENABLE_DEVEL
-include_HEADERS = include/xtables.h
-endif
if ENABLE_STATIC
sbin_PROGRAMS += iptables-static ip6tables-static