summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2008-09-08 15:42:06 +0200
committerPatrick McHardy <kaber@trash.net>2008-09-08 15:42:06 +0200
commit75e8b13c4b3763dc95199b4a22f3d63b7b698119 (patch)
treedbaf5f4f5d6b9ee8caba7f4695d55a78d21b841e /Makefile.am
parent81bd58838403fc8c4a63840f0af42deebe6d4a20 (diff)
build: run ldconfig on `make install`
Reporeted-by: Brent Clark <brentgclarklist@gmail.com> Signed-off-by: Jan Engelhardt <jengelh@medozas.de> Signed-off-by: Patrick McHardy <kaber@trash.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 742e3de0..5465db6c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -107,3 +107,8 @@ tarball:
rm -Rf /tmp/${PACKAGE_TARNAME}-${PACKAGE_VERSION};
config.status: include/xtables.h.in
+
+# ldconfig may fail when we are not root (as is the case in build systems)
+# so add appropriate protection that it does not let `make` fail.
+install-exec-hook:
+ -/sbin/ldconfig || :;