summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2008-01-29 13:32:07 +0000
committerPatrick McHardy <kaber@trash.net>2008-01-29 13:32:07 +0000
commitfb6209a30fd576cd740eefe0a3ad88d65d2bb2b7 (patch)
tree08f9e7c7545c7d4a07179ad0bce3086dbb6e7448 /configure.ac
parent2b62b62509dfccdb6ebbb17628aad95fb7681a89 (diff)
Give preference to iptables header files
Have the header files in the iptables source tree take precedence over those from the kernel source. Otherwise, building the current iptables from subversion just fails with kernels < 2.6.25. Signed-off-by: Jan Engelhardt <jengelh@computergmbh.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 3314df40..e6163297 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,15 +40,15 @@ regular_CFLAGS="-D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 \
-D_REENTRANT -Wall -Waggregate-return -Wmissing-declarations \
-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes \
-Winline -pipe -DIPTABLES_VERSION=\\\"$PACKAGE_VERSION\\\" \
- -DIPT_LIB_DIR=\\\"\${iptdir}\\\" \
- -I\"$kbuilddir/include\" -I\"$ksourcedir/include\""
+ -DIPT_LIB_DIR=\\\"\${iptdir}\\\"";
+kinclude_CFLAGS="-I\"$kbuilddir/include\" -I\"$ksourcedir/include\"";
# Remove workarounds soon
regular_CFLAGS="$regular_CFLAGS -Wno-aggregate-return \
-Wno-missing-declarations -Wno-missing-prototypes \
-Wno-redundant-decls -Wno-shadow -Wno-strict-prototypes -Wno-inline"
-AC_SUBST([regular_CFLAGS])
+AC_SUBST([regular_CFLAGS kinclude_CFLAGS])
AC_SUBST([kbuilddir])
AC_SUBST([ksourcedir])
AC_SUBST([iptdir])