summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2011-06-01 02:20:40 +0200
committerJan Engelhardt <jengelh@medozas.de>2011-06-01 02:21:16 +0200
commit5085c3a037fa9327377dec7540d9c3ef2d53a58e (patch)
tree912f675d250c4108b12e80a82dffea3710861fc6 /configure.ac
parent8e336251e155888f0ac2c79259f8792fc31920a1 (diff)
build: move kinclude's preprocessor flags to kinclude_CPPFLAGS
References: http://bugzilla.netfilter.org/show_bug.cgi?id=713 Signed-off-by: Jan Engelhardt <jengelh@medozas.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 77502fb6..daed602d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -88,18 +88,18 @@ regular_CFLAGS="-Wall -Waggregate-return -Wmissing-declarations \
-Winline -pipe";
regular_CPPFLAGS="${largefile_cppflags} -D_REENTRANT \
-DXTABLES_LIBDIR=\\\"\${xtlibdir}\\\" -DXTABLES_INTERNAL";
-kinclude_CFLAGS="";
+kinclude_CPPFLAGS="";
if [[ -n "$kbuilddir" ]]; then
- kinclude_CFLAGS="$kinclude_CFLAGS -I $kbuilddir/include";
+ kinclude_CPPFLAGS="$kinclude_CPPFLAGS -I$kbuilddir/include";
fi;
if [[ -n "$ksourcedir" ]]; then
- kinclude_CFLAGS="$kinclude_CFLAGS -I $ksourcedir/include";
+ kinclude_CPPFLAGS="$kinclude_CPPFLAGS -I$ksourcedir/include";
fi;
pkgdatadir='${datadir}/xtables';
AC_SUBST([regular_CFLAGS])
AC_SUBST([regular_CPPFLAGS])
-AC_SUBST([kinclude_CFLAGS])
+AC_SUBST([kinclude_CPPFLAGS])
AC_SUBST([kbuilddir])
AC_SUBST([ksourcedir])
AC_SUBST([xtlibdir])