summaryrefslogtreecommitdiffstats
path: root/iptables/Makefile.am
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2011-09-03 13:34:40 +0200
committerJan Engelhardt <jengelh@medozas.de>2011-09-03 13:40:55 +0200
commitd4e72dc1c684c2f8361d87e6bde2902cd2ee8efb (patch)
tree4a8c136fe2219dbea005e6d5728d59238f38e8cc /iptables/Makefile.am
parent2ca6273c73b42e8c74afd5f8b1fe10c5c93ce363 (diff)
libxt_statistic: link with -lm
$ ldd -r libxt_statistic.so undefined symbol: lround (./libxt_statistic.so) References: https://bugs.archlinux.org/task/25358 Signed-off-by: Jan Engelhardt <jengelh@medozas.de>
Diffstat (limited to 'iptables/Makefile.am')
-rw-r--r--iptables/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/iptables/Makefile.am b/iptables/Makefile.am
index addb1598..f6db32d0 100644
--- a/iptables/Makefile.am
+++ b/iptables/Makefile.am
@@ -6,12 +6,17 @@ AM_CPPFLAGS = ${regular_CPPFLAGS} -I${top_builddir}/include -I${top_srcdir}
lib_LTLIBRARIES = libxtables.la
libxtables_la_SOURCES = xtables.c xtoptions.c
libxtables_la_LDFLAGS = -version-info ${libxtables_vcurrent}:0:${libxtables_vage}
+libxtables_la_LIBADD =
+if ENABLE_STATIC
+# With --enable-static, shipped extensions are linked into the main executable,
+# so we need all the LIBADDs here too
+libxtables_la_LIBADD += -lm
+endif
if ENABLE_SHARED
libxtables_la_CFLAGS = ${AM_CFLAGS}
-libxtables_la_LIBADD = -ldl
+libxtables_la_LIBADD += -ldl
else
libxtables_la_CFLAGS = ${AM_CFLAGS} -DNO_SHARED_LIBS=1
-libxtables_la_LIBADD =
endif
xtables_multi_SOURCES = xtables-multi.c iptables-xml.c