summaryrefslogtreecommitdiffstats
path: root/iptables/Makefile.am
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2011-09-18 15:06:05 +0200
committerJan Engelhardt <jengelh@medozas.de>2011-09-19 13:42:32 +0200
commit8816e91cddef785c78b3598c7c41a1f88be08f5a (patch)
treed15e6d27f9c39c1d9a4004c40803bb67ccb72a9c /iptables/Makefile.am
parent1e4965232d77ab752c9c781afcf854f4b173c7b1 (diff)
build: restore build order of modules
iptables(exe) requires libext.a, but extensions/ require libxtables.la (in iptables/). This circular dependency does not work out, so separate libxtables into its own directory and put it in front. Signed-off-by: Jan Engelhardt <jengelh@medozas.de>
Diffstat (limited to 'iptables/Makefile.am')
-rw-r--r--iptables/Makefile.am18
1 files changed, 1 insertions, 17 deletions
diff --git a/iptables/Makefile.am b/iptables/Makefile.am
index af620f76..bdd4da11 100644
--- a/iptables/Makefile.am
+++ b/iptables/Makefile.am
@@ -3,22 +3,6 @@
AM_CFLAGS = ${regular_CFLAGS}
AM_CPPFLAGS = ${regular_CPPFLAGS} -I${top_builddir}/include -I${top_srcdir}/include ${kinclude_CPPFLAGS}
-lib_LTLIBRARIES = libxtables.la
-libxtables_la_SOURCES = xtables.c xtoptions.c
-libxtables_la_LDFLAGS = -version-info ${libxtables_vcurrent}:0:${libxtables_vage}
-libxtables_la_LIBADD =
-if ENABLE_STATIC
-# With --enable-static, shipped extensions are linked into the main executable,
-# so we need all the LIBADDs here too
-libxtables_la_LIBADD += -lm
-endif
-if ENABLE_SHARED
-libxtables_la_CFLAGS = ${AM_CFLAGS}
-libxtables_la_LIBADD += -ldl
-else
-libxtables_la_CFLAGS = ${AM_CFLAGS} -DNO_SHARED_LIBS=1
-endif
-
xtables_multi_SOURCES = xtables-multi.c iptables-xml.c
xtables_multi_CFLAGS = ${AM_CFLAGS}
xtables_multi_LDADD = ../extensions/libext.a
@@ -38,7 +22,7 @@ xtables_multi_CFLAGS += -DENABLE_IPV6
xtables_multi_LDADD += ../libiptc/libip6tc.la ../extensions/libext6.a
endif
xtables_multi_SOURCES += xshared.c
-xtables_multi_LDADD += libxtables.la -lm
+xtables_multi_LDADD += ../libxtables/libxtables.la -lm
sbin_PROGRAMS = xtables-multi
man_MANS = iptables.8 iptables-restore.8 iptables-save.8 \