summaryrefslogtreecommitdiffstats
path: root/libxtables/Makefile.am
diff options
context:
space:
mode:
authorPhil Sutter <phil@nwl.cc>2018-09-19 15:16:44 +0200
committerFlorian Westphal <fw@strlen.de>2018-09-24 11:23:46 +0200
commit31f1434dfe3770ecbdac1bacb8e0fc4a17b3d671 (patch)
tree0816392be62930436e984e1300c088fdf8f4d551 /libxtables/Makefile.am
parent7ae4fb1348874afbfd760d6b7a24e4ea2d6e67ab (diff)
libxtables: Integrate getethertype.c from xtables core
This moves getethertype.c into libxtables so that both extensions and xtables-nft-multi may use the implementations therein. New users are libebt_arp and libebt_vlan which drop their own duplicated implementations of getethertypebyname() for the shared one. This change originated from a covscan report of extensions' implementations not checking fopen() return value which should be implicitly fixed by this as well. Signed-off-by: Phil Sutter <phil@nwl.cc> Signed-off-by: Florian Westphal <fw@strlen.de>
Diffstat (limited to 'libxtables/Makefile.am')
-rw-r--r--libxtables/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libxtables/Makefile.am b/libxtables/Makefile.am
index 4267cb5f..8ff6b0ca 100644
--- a/libxtables/Makefile.am
+++ b/libxtables/Makefile.am
@@ -4,7 +4,7 @@ AM_CFLAGS = ${regular_CFLAGS}
AM_CPPFLAGS = ${regular_CPPFLAGS} -I${top_builddir}/include -I${top_srcdir}/include -I${top_srcdir}/iptables ${kinclude_CPPFLAGS}
lib_LTLIBRARIES = libxtables.la
-libxtables_la_SOURCES = xtables.c xtoptions.c
+libxtables_la_SOURCES = xtables.c xtoptions.c getethertype.c
libxtables_la_LDFLAGS = -version-info ${libxtables_vcurrent}:0:${libxtables_vage}
libxtables_la_LIBADD =
if ENABLE_STATIC