summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2010-11-19 13:09:52 +0100
committerPablo Neira Ayuso <pablo@netfilter.org>2010-11-19 13:09:52 +0100
commitb28767d124d074a0e8937ee880b2fe54ccc823b4 (patch)
tree06c10a1fcdfc8619216fab409f3dd33bb176ce42 /configure.ac
parentfe73d7d8854efda86d4d09757874c48352e6b247 (diff)
ld: add some more precautionary CFLAGS
Signed-off-by: Jan Engelhardt <jengelh@medozas.de> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 74efa45..6443581 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,5 +17,10 @@ case $target in
*) AC_MSG_ERROR([Linux only, dude!]);;
esac
+regular_CFLAGS="-D_FILE_OFFSET_BITS=64 \
+ -D_REENTRANT -Wall -Waggregate-return -Wmissing-declarations \
+ -Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes \
+ -Wformat=2 -pipe"
+AC_SUBST([regular_CFLAGS])
AC_CONFIG_FILES([Makefile src/Makefile include/Makefile include/libmnl/Makefile examples/Makefile examples/genl/Makefile examples/netfilter/Makefile examples/rtnl/Makefile libmnl.pc doxygen.cfg])
AC_OUTPUT