summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2010-10-19 12:00:01 +0200
committerJan Engelhardt <jengelh@medozas.de>2010-10-19 12:10:53 +0200
commitecf8c9f80fd69009d1e6af7d9f411b78fd9b5bea (patch)
tree91996cf65f11fd035ec7e1e03c40b25a8e55644b /configure.ac
parent5f79ee7952548e37b3c237142d33a158d10c6fc7 (diff)
build: run autoupdate
Macro usage has changed over the last few years. Update it to the current specification using autoupdate(1). Manually update INCLUDES -> CPPFLAGS, because autoupdate did not catch that. Remove $(all_includes) and $(LIBS) because it is not used anywhere. Signed-off-by: Jan Engelhardt <jengelh@medozas.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 6a199c4..d9567ea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,14 +1,14 @@
dnl Process this file with autoconf to create configure.
AC_INIT([libmnl], [1.0.0-beta0])
-AC_CANONICAL_SYSTEM
+AC_CANONICAL_TARGET
AC_CONFIG_MACRO_DIR([m4])
AM_INIT_AUTOMAKE([foreign dist-bzip2 1.6 subdir-objects])
AC_PROG_CC
AM_PROG_CC_C_O
AC_EXEEXT
-AM_PROG_LIBTOOL
+LT_INIT
AC_SUBST(LIBTOOL_DEPS)
case $target in
@@ -16,4 +16,5 @@ case $target in
*) AC_MSG_ERROR([Linux only, dude!]);;
esac
-AC_OUTPUT(Makefile src/Makefile include/Makefile include/libmnl/Makefile examples/Makefile examples/genl/Makefile examples/netfilter/Makefile examples/rtnl/Makefile libmnl.pc doxygen.cfg)
+AC_CONFIG_FILES([Makefile src/Makefile include/Makefile include/libmnl/Makefile examples/Makefile examples/genl/Makefile examples/netfilter/Makefile examples/rtnl/Makefile libmnl.pc doxygen.cfg])
+AC_OUTPUT