summaryrefslogtreecommitdiffstats
path: root/extensions/Makefile.am
diff options
context:
space:
mode:
author/C=DE/ST=Berlin/L=Berlin/O=Netfilter Project/OU=Development/CN=laforge/emailAddress=laforge@netfilter.org </C=DE/ST=Berlin/L=Berlin/O=Netfilter Project/OU=Development/CN=laforge/emailAddress=laforge@netfilter.org>2005-11-06 11:34:35 +0000
committer/C=DE/ST=Berlin/L=Berlin/O=Netfilter Project/OU=Development/CN=laforge/emailAddress=laforge@netfilter.org </C=DE/ST=Berlin/L=Berlin/O=Netfilter Project/OU=Development/CN=laforge/emailAddress=laforge@netfilter.org>2005-11-06 11:34:35 +0000
commitd0a9ad5275bcc7b87200724ee9294e9f456ff17f (patch)
treec8e1d0d13472e8a82aa78176f7a8dc581596eff7 /extensions/Makefile.am
parent93022769c4a822e613f11cf64b444d58d6b9ed97 (diff)
introduce library API versioning and plugin release handling
Diffstat (limited to 'extensions/Makefile.am')
-rw-r--r--extensions/Makefile.am12
1 files changed, 4 insertions, 8 deletions
diff --git a/extensions/Makefile.am b/extensions/Makefile.am
index 703af56..b5a343e 100644
--- a/extensions/Makefile.am
+++ b/extensions/Makefile.am
@@ -1,9 +1,5 @@
AUTOMAKE_OPTIONS = no-dependencies foreign
-EXTRA_DIST = $(man_MANS)
-
-man_MANS =
-
INCLUDES=-I../include -I${KERNELDIR}
CFLAGS=-fPIC -Wall
LIBS=
@@ -12,17 +8,17 @@ pkglib_LTLIBRARIES = nfct_proto_tcp.la nfct_proto_udp.la \
nfct_proto_icmp.la nfct_proto_sctp.la
nfct_proto_tcp_la_SOURCES = libnetfilter_conntrack_tcp.c
-nfct_proto_tcp_la_LDFLAGS = -module
+nfct_proto_tcp_la_LDFLAGS = -module -avoid-version -release $(VERSION)
nfct_proto_tcp_la_LIBADD = ../src/libnetfilter_conntrack.la
nfct_proto_udp_la_SOURCES = libnetfilter_conntrack_udp.c
-nfct_proto_udp_la_LDFLAGS = -module
+nfct_proto_udp_la_LDFLAGS = -module -avoid-version -release $(VERSION)
nfct_proto_udp_la_LIBADD = ../src/libnetfilter_conntrack.la
nfct_proto_icmp_la_SOURCES = libnetfilter_conntrack_icmp.c
-nfct_proto_icmp_la_LDFLAGS = -module
+nfct_proto_icmp_la_LDFLAGS = -module -avoid-version -release $(VERSION)
nfct_proto_icmp_la_LIBADD = ../src/libnetfilter_conntrack.la
nfct_proto_sctp_la_SOURCES = libnetfilter_conntrack_sctp.c
-nfct_proto_sctp_la_LDFLAGS = -module
+nfct_proto_sctp_la_LDFLAGS = -module -avoid-version -release $(VERSION)
nfct_proto_sctp_la_LIBADD = ../src/libnetfilter_conntrack.la