summaryrefslogtreecommitdiffstats
path: root/src/conntrack/Makefile.am
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@netfilter.org>2012-04-13 13:13:34 +0200
committerPablo Neira Ayuso <pablo@netfilter.org>2012-05-26 16:10:34 +0200
commit95b3bf6576165e1bbe23d55d5f15b7ebf9c98dc4 (patch)
treec1df552ea77057aaf83ca7b0f00504d0cdaf7d0d /src/conntrack/Makefile.am
parenta84175b8c3b167bf0e18a9ce1f6bb48a62c64127 (diff)
conntrack: add new API to build/parse ctnetlink messages using libmnl
This patch adds support to build and to parse netlink messages from/to one user-space nf_conntrack object. It uses libmnl, thus libnetfilter_conntrack now depends on this library. This is the first patch in the direction of removing the dependency on the veteran libnfnetlink. I have decided to update LIBVERSION in this patch. I know it's recommended to do this before releasing the software. I prefer to do this so snapshot packages get the correct LIBVERSION. Signed-off-by: Pablo Neira Ayuso <pablo@gnumonks.org>
Diffstat (limited to 'src/conntrack/Makefile.am')
-rw-r--r--src/conntrack/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/conntrack/Makefile.am b/src/conntrack/Makefile.am
index 3f7fb64..01fed53 100644
--- a/src/conntrack/Makefile.am
+++ b/src/conntrack/Makefile.am
@@ -5,6 +5,7 @@ noinst_LTLIBRARIES = libnfconntrack.la
libnfconntrack_la_SOURCES = api.c \
getter.c setter.c \
parse.c build.c \
+ parse_mnl.c build_mnl.c \
snprintf.c \
snprintf_default.c snprintf_xml.c \
objopt.c \