summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@netfilter.org>2010-07-11 17:19:12 +0200
committerPablo Neira Ayuso <pablo@netfilter.org>2010-07-11 17:27:54 +0200
commitc5d0a0342677db2969c1119bc0f9a0a0753eaadf (patch)
treeb311484a85c4a76fb446eaf250963ff39ba50393 /Makefile.am
parent895c800290f447d042ce0f70e49e2bf0dbe0c6fc (diff)
nfq: bump version to 1.0.0libnetfilter_queue-1.0.0
This patch bumps the library version to 1.0. I have also introduced LIBVERSION for the API versioning. Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 28641f8..a88f285 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,25 @@
+# This is _NOT_ the library release version, it's an API version.
+# Extracted from Chapter 6 "Library interface versions" of the libtool docs.
+#
+# <snippet>
+# Here are a set of rules to help you update your library version information:
+#
+# 1. Start with version information of `0:0:0' for each libtool library.
+# 2. Update the version information only immediately before a public release
+# of your software. More frequent updates are unnecessary, and only guarantee
+# that the current interface number gets larger faster.
+# 3. If the library source code has changed at all since the last update,
+# then increment revision (`c:r:a' becomes `c:r+1:a').
+# 4. If any interfaces have been added, removed, or changed since the last
+# update, increment current, and set revision to 0.
+# 5. If any interfaces have been added since the last public release, then
+# increment age.
+# 6. If any interfaces have been removed since the last public release, then
+# set age to 0.
+# </snippet>
+#
+LIBVERSION=1:0:1
+
AUTOMAKE_OPTIONS = foreign dist-bzip2 1.6
ACLOCAL_AMFLAGS = -I m4