summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@netfilter.org>2010-11-01 22:32:35 +0100
committerPablo Neira Ayuso <pablo@netfilter.org>2010-11-01 22:32:35 +0100
commitc4692e02d4fc804f7aa31f407d7d2f31861753bc (patch)
tree1f38fbe970c16fb68356e2d94aec0898500b0615 /configure.ac
parent81284db9f861f964cc0a5c756a1fa375e586c309 (diff)
parentddd8ea0add4eb4390763d066d0673c6d94dec1f3 (diff)
Merge branch 'master' of git://dev.medozas.de/libnetfilter_queue
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..c4cc36e
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,25 @@
+dnl Process this file with autoconf to create configure.
+
+AC_INIT([libnetfilter_queue], [1.0.0])
+AC_CANONICAL_HOST
+AC_CONFIG_MACRO_DIR([m4])
+
+AM_INIT_AUTOMAKE([-Wall foreign subdir-objects dist-bzip2 1.6])
+
+AC_PROG_CC
+AC_EXEEXT
+AM_PROG_LIBTOOL
+AC_PROG_INSTALL
+
+AC_SUBST(LIBTOOL_DEPS)
+
+case "$host" in
+*-*-linux*) ;;
+*) AC_MSG_ERROR([Linux only, dude!]);;
+esac
+
+dnl Dependencies
+PKG_CHECK_MODULES([LIBNFNETLINK], [libnfnetlink >= 0.0.41])
+
+dnl Output the makefiles
+AC_OUTPUT(Makefile include/Makefile include/libnetfilter_queue/Makefile src/Makefile utils/Makefile libnetfilter_queue.pc doxygen.cfg)