summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d8d1d38..32e4990 100644
--- a/configure.ac
+++ b/configure.ac
@@ -41,6 +41,10 @@ AC_ARG_WITH([doxygen], [AS_HELP_STRING([--with-doxygen],
[], [with_doxygen=no])
AS_IF([test "x$with_doxygen" = xyes], [
AC_CHECK_PROGS([DOXYGEN], [doxygen])
+ AC_CHECK_PROGS([DOT], [dot], [""])
+ AS_IF([test "x$DOT" != "x"],
+ [AC_SUBST(HAVE_DOT, YES)],
+ [AC_SUBST(HAVE_DOT, NO)])
])
AM_CONDITIONAL([HAVE_DOXYGEN], [test -n "$DOXYGEN"])