summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2010-10-30 23:16:43 +0200
committerJan Engelhardt <jengelh@medozas.de>2010-10-30 23:45:16 +0200
commit7bb2942c276f13360f166d8e7ef9f9e5573af9d7 (patch)
tree0437c9f627db565920062683db32d495f48baa03 /configure.ac
parent54c8cf1853e97dcaa974c9f44297f94619f1d880 (diff)
build: use autoconf-suggested naming of files
Signed-off-by: Jan Engelhardt <jengelh@medozas.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..47f3551
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,25 @@
+dnl Process this file with autoconf to create configure.
+
+AC_INIT(libnfnetlink, 1.0.0)
+
+AC_CANONICAL_SYSTEM
+
+AM_INIT_AUTOMAKE
+
+AC_PROG_CC
+AC_EXEEXT
+AM_PROG_LIBTOOL
+AC_SUBST(LIBTOOL_DEPS)
+
+case $target in
+*-*-linux*) ;;
+*) AC_MSG_ERROR([Linux only, dude!]);;
+esac
+
+
+dnl--------------------------------
+dnl--------------------------------
+
+
+dnl Output the makefile
+AC_OUTPUT(Makefile src/Makefile include/Makefile include/libnfnetlink/Makefile utils/Makefile libnfnetlink.pc)