summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDouglas Freed <dwfreed@mtu.edu>2013-12-23 09:14:57 +0000
committerPablo Neira Ayuso <pablo@netfilter.org>2013-12-23 13:43:29 +0100
commit24e08e5ecd81c1570d2521f354acfb341d8e9ce4 (patch)
tree4dfcd2a4a16bae2be23af14e4ff1498fda812097 /configure.ac
parent2307124fe813e2d2d7e1a7bab09076a5a961e79b (diff)
build: properly handle --without-{xml,json}-parsing
This patch fixes how --without-{xml,json}-parsing (and subsequently --with-{xml,json}-parsing=no) is handled. Prior to this, --without-{xml,json}-parsing actually resulted in libnftables being built with that parsing enabled. Signed-off-by: Douglas Freed <dwfreed@mtu.edu> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index b023755..6219737 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,11 +16,9 @@ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
dnl Dependencies
PKG_CHECK_MODULES([LIBMNL], [libmnl >= 1.0.0])
AC_ARG_WITH([xml-parsing],
- AS_HELP_STRING([--with-xml-parsing], [XML parsing support]),
- [with_xml_parsing="yes"], [with_xml_parsing="no"])
+ AS_HELP_STRING([--with-xml-parsing], [XML parsing support]))
AC_ARG_WITH([json-parsing],
- AS_HELP_STRING([--with-json-parsing], [JSON parsing support]),
- [with_json_parsing="yes"], [with_json_parsing="no"])
+ AS_HELP_STRING([--with-json-parsing], [JSON parsing support]))
AS_IF([test "x$with_xml_parsing" = "xyes"], [
PKG_CHECK_MODULES([LIBXML], [mxml >= 2.6])