summaryrefslogtreecommitdiffstats
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorArturo Borrero <arturo.borrero.glez@gmail.com>2014-08-18 21:06:14 +0200
committerPablo Neira Ayuso <pablo@netfilter.org>2014-08-18 22:17:56 +0200
commit83694bec010c247a9d08124edde99ac9728e74a1 (patch)
treeb5bb89b91f6007829c9e353ca3be0705c2b73308 /examples/Makefile.am
parent3a5d8b38f288c2f59a4045983e0734498b932770 (diff)
examples: merge nft-chain-{xml|json}-add.c
Merge the two examples in one. Use an input argument to choose the format to parse. Signed-off-by: Arturo Borrero Gonzalez <arturo.borrero.glez@gmail.com> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am10
1 files changed, 3 insertions, 7 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index c45b9df..f35924d 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -7,8 +7,7 @@ check_PROGRAMS = nft-table-add \
nft-table-del \
nft-table-get \
nft-chain-add \
- nft-chain-xml-add \
- nft-chain-json-add \
+ nft-chain-parse-add \
nft-chain-del \
nft-chain-get \
nft-rule-add \
@@ -48,11 +47,8 @@ nft_table_get_LDADD = ../src/libnftnl.la ${LIBMNL_LIBS}
nft_chain_add_SOURCES = nft-chain-add.c
nft_chain_add_LDADD = ../src/libnftnl.la ${LIBMNL_LIBS}
-nft_chain_xml_add_SOURCES = nft-chain-xml-add.c
-nft_chain_xml_add_LDADD = ../src/libnftnl.la ${LIBMNL_LIBS}
-
-nft_chain_json_add_SOURCES = nft-chain-json-add.c
-nft_chain_json_add_LDADD = ../src/libnftnl.la ${LIBMNL_LIBS} ${LIBXML_LIBS} ${LIBJSON_LIBS}
+nft_chain_parse_add_SOURCES = nft-chain-parse-add.c
+nft_chain_parse_add_LDADD = ../src/libnftnl.la ${LIBMNL_LIBS}
nft_chain_del_SOURCES = nft-chain-del.c
nft_chain_del_LDADD = ../src/libnftnl.la ${LIBMNL_LIBS}