summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorLaura Garcia Liebana <nevola@gmail.com>2016-08-13 01:02:03 +0200
committerPablo Neira Ayuso <pablo@netfilter.org>2016-08-17 15:52:58 +0200
commit48a71a20420e307d0a1d8a89ac9fc7b46ec5a1ca (patch)
tree00858dc8a09fb9991358d6cca1468ba3fbea143d /tests/Makefile.am
parentaf494b6878ed605e3b52d13e6aba023f3cd985ca (diff)
expr: add hash expression
Support for the nft hash expression in libnftnl. Signed-off-by: Laura Garcia Liebana <nevola@gmail.com> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 0377081..86766f3 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -29,7 +29,8 @@ check_PROGRAMS = nft-parsing-test \
nft-expr_queue-test \
nft-expr_redir-test \
nft-expr_reject-test \
- nft-expr_target-test
+ nft-expr_target-test \
+ nft-expr_hash-test
nft_parsing_test_SOURCES = nft-parsing-test.c
nft_parsing_test_LDADD = ../src/libnftnl.la ${LIBMNL_LIBS} ${LIBXML_LIBS} ${LIBJSON_LIBS}
@@ -108,3 +109,6 @@ nft_expr_redir_test_LDADD = ../src/libnftnl.la ${LIBMNL_LIBS}
nft_expr_target_test_SOURCES = nft-expr_target-test.c
nft_expr_target_test_LDADD = ../src/libnftnl.la ${LIBMNL_LIBS}
+
+nft_expr_hash_test_SOURCES = nft-expr_hash-test.c
+nft_expr_hash_test_LDADD = ../src/libnftnl.la ${LIBMNL_LIBS}