summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@netfilter.org>2016-11-27 23:26:56 +0100
committerPablo Neira Ayuso <pablo@netfilter.org>2016-12-09 14:50:53 +0100
commit5573d0146c1ae71ac5b3e4ba6a12c00585646a1a (patch)
treed6e4938b3a51d5973b7ac6c1a21f2705f5ad10c1 /tests/Makefile.am
parent85894febe35d223c0478dfac56dcd7366609f981 (diff)
src: support for stateful objects
This patch allows you to add, to delete and to get stateful objects, this support two object types: counter and quota. Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index d518959..812ebff 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -6,6 +6,7 @@ EXTRA_DIST = test-script.sh \
check_PROGRAMS = nft-parsing-test \
nft-table-test \
nft-chain-test \
+ nft-object-test \
nft-rule-test \
nft-set-test \
nft-expr_bitwise-test \
@@ -43,6 +44,9 @@ nft_table_test_LDADD = ../src/libnftnl.la ${LIBMNL_LIBS}
nft_chain_test_SOURCES = nft-chain-test.c
nft_chain_test_LDADD = ../src/libnftnl.la ${LIBMNL_LIBS}
+nft_object_test_SOURCES = nft-object-test.c
+nft_object_test_LDADD = ../src/libnftnl.la ${LIBMNL_LIBS}
+
nft_rule_test_SOURCES = nft-rule-test.c
nft_rule_test_LDADD = ../src/libnftnl.la ${LIBMNL_LIBS}