summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 0 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index dbb723d..d05532d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,13 +15,6 @@ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
dnl Dependencies
PKG_CHECK_MODULES([LIBMNL], [libmnl >= 1.0.3])
-AC_ARG_WITH([json-parsing],
- AS_HELP_STRING([--with-json-parsing], [JSON parsing support]))
-
-AS_IF([test "x$with_json_parsing" = "xyes"],
- [PKG_CHECK_MODULES([LIBJSON], [jansson >= 2.3])],
- [with_json_parsing="no"]
-)
AC_PROG_CC
AM_PROG_CC_C_O
AC_EXEEXT
@@ -35,9 +28,6 @@ esac
regular_CPPFLAGS="-D_FILE_OFFSET_BITS=64 -D_REENTRANT"
-AS_IF([test "x$with_json_parsing" = "xyes"], [
- regular_CPPFLAGS="$regular_CPPFLAGS -DJSON_PARSING"
-])
regular_CFLAGS="-Wall -Waggregate-return -Wmissing-declarations \
-Wmissing-prototypes -Wshadow -Wstrict-prototypes \
-Wformat=2 -Wwrite-strings -pipe"
@@ -45,7 +35,3 @@ AC_SUBST([regular_CPPFLAGS])
AC_SUBST([regular_CFLAGS])
AC_CONFIG_FILES([Makefile src/Makefile include/Makefile include/libnftnl/Makefile include/linux/Makefile include/linux/netfilter/Makefile examples/Makefile tests/Makefile libnftnl.pc doxygen.cfg])
AC_OUTPUT
-
-echo "
-libnftnl configuration:
- JSON support: ${with_json_parsing}"