summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..b1c1044
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,21 @@
+include $(top_srcdir)/Make_global.am
+lib_LTLIBRARIES = libnftables.la
+
+libnftables_la_LIBADD = ${LIBMNL_LIBS}
+libnftables_la_LDFLAGS = -Wl,--version-script=$(srcdir)/libnftables.map \
+ -version-info $(LIBVERSION)
+libnftables_la_SOURCES = table.c \
+ chain.c \
+ rule.c \
+ expr.c \
+ expr_ops.c \
+ expr/cmp.c \
+ expr/counter.c \
+ expr/data_reg.c \
+ expr/immediate.c \
+ expr/match.c \
+ expr/meta.c \
+ expr/payload.c \
+ expr/target.c \
+ libnftables.map \
+ internal.h