summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..5c09b24
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,26 @@
+include $(top_srcdir)/Make_global.am
+
+sbin_PROGRAMS = nft-sync
+
+AM_YFLAGS = -d
+
+CLEANFILES = config-parser.c \
+ config-scanner.c
+
+nft_sync_SOURCES = event.c \
+ logging.c \
+ msg_buff.c \
+ server.c \
+ client.c \
+ tcp.c \
+ timer.c \
+ main.c \
+ fd.c \
+ config-parser.y \
+ config-scanner.l
+nft_sync_LDADD = ${LIBMNL_LIBS} ${LIBNFTNL_LIBS} -lev
+
+# yacc and lex generate dirty code
+config-scanner.o config-parser.o: AM_CFLAGS += -Wno-missing-prototypes -Wno-missing-declarations -Wno-implicit-function-declaration -Wno-nested-externs -Wno-undef -Wno-redundant-decls
+
+EXTRA_DIST = config-parser.h